Home - , , - iOS 8 Update Enables LTE on T-Mobile MVNOs

iOS 8 Update Enables LTE on T-Mobile MVNOs


Do you have an iPhone on an independent T-Mobile MVNO that supports LTE like Ultra Mobile, PTel or Giv Mobile? Does LTE work for you? I'm guessing probably not. There's a bug (or is it a feature?) in iOS 7 and earlier that prevents LTE from working with any operator, including MVNOs, that isn't an official Apple partner.

According to T-Mobile MVNO Ultra Mobile, iOS 8 fixes the bug and Ultra iPhone users who upgrade to the latest iOS are finally able to use LTE. After upgrading to iOS 8, you just need update your iPhone's cellular data settings as follows:
  • Tap the Settings icon then tap Cellular then Cellular Data Network
  • Scroll down to Cellular Data and tap and set APN: to wholesale
  • Scroll to MMS and tap and set the following:
  • APN: wholesale
  • MMSC: http://wholesale.mmsmvno.com/mms/wapenc
  • MMS Proxy: 216.155.165.50 :8080
  • Tap Cellular
  • Press the Home button
  • Power the iPhone off by holding down the power button
Turn the iPhone back on and you should have working LTE. In addition to Ultra Mobile, the above settings should also work with PTel and Giv Mobile. For other T-Mobile MVNOs, check your operator's web page or call them for their recommended iOS data settings.

I don't have an iPhone to test this with but if you do please let us all know if it worked or not.

Source, image: Ultra Mobile on Facebook

20 comments:

Comment Page :
  1. Dennis, do you know if the at&t iPhone 6/+ works in T-Mobile without unlocking and fully uses T-Mobile bands? Thank you

    ReplyDelete
    Replies
    1. Locked phone is locked network freq bands. Defined based on MCC and MNC. Want freedom? Buy unlocked phone.

      Delete
    2. The AT&T iPhone 6 is locked. It will need to be unlocked to accept a T-Mobile SIM. The AT&T and T-Mobile iPhones support the same bands including T-Mobile's Band 4 LTE and AWS 3G/fauxG.

      Delete
  2. Dear Lord! LTE on T-Mobile's network. While great when you are in an LTE area, DO NOT venture away from a downtown or interstate or welcome to the 2G Edge land of the lost!!!!

    ReplyDelete
    Replies
    1. They're activately upgrading 2G sites to LTE (some skipping 3G/HSPA+ and just re-using existing 1900MHz antennas). Goal is to have all 2G markets to LTE by summer 2015.

      Here in Central Valley some rural / middle of nowhere sites have been converted.

      Delete
    2. Ya, it seems it's LTE, or edge. Seems they skipped 3g or hspa whatever.

      Delete
    3. The upgrades are happening very fast. I know this first hand. I have a non-AWS phone and was getting EDGE around my work and home, but 3G (HSPA+) along my commute. And one day, bam, I had 3G coverage at home. Literally 2 days later, I had 3G coverage at work. I've driven around the SF Bay Area and the 1900band for 3G/HSPA is up in most places. There are only small pockets of EDGE on 1900band, Speed in HSPA is already quite good.

      Delete
  3. Why do Ultra and PTel use the same data settings but other T Mobile MVNOs use different settings?

    Do Verizon iPhone 6 models support the same bands as the T Mobile iPhone 6?

    ReplyDelete
    Replies
    1. I believe that the "wholesale" APN that PTel and Ultra use is T-Mobile's generic one for MVNOs. Other MVNOs may use a different APN that contains their company name probably just for branding.

      The Verizon iPhone 6 supports all of T-Mobile's currently used bands.

      Delete
  4. Does iOS 8 allow LTE on MVNOs that run on other networks?

    ReplyDelete
  5. Although I'm fairly certain T-Mobile MVNO BrightSpot Mobile does not offer LTE, I still get the option to switch on LTE, which is good. No LTE speed, though. There are other reasons not to use BrightSpot. I would not recommend it. At all.

    ReplyDelete
    Replies
    1. It may. So far I haven't heard of any where that was the case. If I do I'll update the post.

      Delete
    2. What are the other reasons not to use Brightspot?

      Delete
    3. @Anonymous "What are the other reasons not to use Brightspot?"

      For me, the problems are: no 4G or 4G LTE on iPhone 5, restrictive terms of service, telephone customer service designed to ensure you have the worst experience possible (yes, worse than Comcast), plus the basic short codes for retrieving information about account status stopped working after two weeks, access to the web site blocked for 5 weeks (customer service had to delete my original profile and I had to start a new one, which ... yes ... stopped working again after two weeks) and to top it all off, after one month of service and never reaching the 3GB barrier before throttling, my data was never reset so I've been at slower-than-dialup speeds the entire second month—customer service insists I used 3GB of "fast" data in just under 48 hours.

      The only reason I still have it is I foolishly purchased approximately four months of service, because it was on sale. Never again.

      Delete
    4. Thanks for the heads up. What are the restrictive terms of service?

      Delete
  6. "There's a bug ( or is it a feature?) in IOS7 and earlier than prevents LTE from working..."
    DEFINITELY a "FEATURE " knowing Apple's underhanded ways!

    ReplyDelete
  7. I confirm that iOS 8, together with the new Carrier Settings 17 update turned on LTE for my iPhone 5C on Ptel. This doubled my average download speed, made my upload speed about 5X faster and cut my ping time in half.

    ReplyDelete
  8. I use a rural cellular company that uses their own cellular towers and IOS8 made LTE work on our network, isn't restricted to t-mob

    ReplyDelete
    Replies
    1. Which carrier are you using?

      Delete
  9. I am using a T-Mobile iphone 5s that is NOT unlocked with a Straight Talk sim card that is the T-Mobile version. Before I updated to ios 8 I had MMs, data and all other features working properly except for LTE. I updated to ios 8and now all features work and I have LTE but I no longer have MMS. I tried these settings and they did not work. I was wondering if anyone has this same problem or a solution? Thanks guys.

    ReplyDelete
Comment Page :